Troubleshoot and Debug
-
Check the Logs file of MID Server in case of failures. Logs are stored at
<Mid Server installation path> / agent/log/
.- agent0.log.0
- Wrapper.log
-
Enable the logging and set the Log Level to 4 and perform the operation. All details are recorded into a wrapper.log file.
-
When the logging level is set to 4 and the lookups are turned ON then the wrapper.log at MID Server stores the IP, DNS and FQDN for a request. These values can be compared with the one stored in PAS to check if the failure is due to mismatch of IP, DNS or FQDN.
Debugging Scenarios and Tips
Scenario 1
The user gets an Authentication failed message on validation.
Cause 1
This happens when a Credential resolver can fetch the credential successfully, but it’s not authorizing with the provided credentials.
Resolution 1
- Confirm that the system or a target is added into PAS.
- Confirm that the service user has Checkout permission of an Account.
- Confirm that the WebApp is permitted to a service user being used in
config.xml
of MID Server. - Confirm that the parameters passed in
config.xml
file. - Confirm that the extlib folder in MID Server contains the expected file.
Scenario 2
Users might experience performance issues in bulk discovery.
Cause 2
A plugin has a retry mechanism and DNS look up features. You can experience performance issues when these are configured. The plugin tries to look up the information one-by-one using all three lookup parameters. If it fails to get the information, it will retry based on the configuration setting. This process is time-consuming.
Resolution 2
- Avoid using all the lookup parameters unless required. For example, if all the systems in PAS are enrolled with FQDN, then use only FQDN in the lookup order.
- Try to keep retry attempts at a minimum.
Scenario 3
User gets a timeout message on credential validation.
Cause 3
This happens when a ServiceNow MID Server timeout exceeds the retry interval.
Resolution 3
Check the retry interval and retry attempts values in the config.xml
and set a lower value for retry intervals and attempt.
Scenario 4
If the DelineaCredCache.properties file is not created in the Agent folder.
Cause 4
This happens when the plugin failed to fetch the Mid Server folder location.
Resolution 4
Check the location of the Agent folder and whether it exists or not.
Scenario 5
If you are unable to decrypt the credentials.
Resolution 5
- Ensure that the EncryptCredential jar is running on the same server as the Mid Server.
- Ensure that the tags copied correctly.
Scenario 6
Getting an error while running the EncryptCredential.jar file.
Resolution 6
Ensure Java version is 11 or above by running "Java -version" command.